Payment processing issue

Major incident Webpage Mainhost (GalaxyGate) DootDoot bot
2020-05-23 02:03 CEST · 11 hours, 20 minutes

Updates

Resolved

Issue with payment processing has been solved and service should be back online

November 4, 2021 · 16:24 CEST
Issue

Due to issue with my bank and paypall there was issue with payment for VPS
Service should be restored withing 24h.

November 4, 2021 · 16:24 CEST

← Back